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Overview 
A common GIS development task is the need to digitize data off of a paper map. There are two main 
ways to do this: 

1. Digitize using a digitizing tablet. 
2. On-screen digitizing from a background (scanned) image of the map. 

This document describes part of the process for on-screen (#2) digitizing: Getting a background image 
georeferenced so that you can do online digitizing using it, or simply use it as another GIS (raster) 
layer. 



1. First, you must identify the map you want to digitize and check it for metadata. 
1. Check for georeferencing coordinates (are there long/lat lines on the map? UTM 

coordinates? What kind of datum/map projection is it in?) (See Appendix A for an 
example from a USGS topomap). 

2. You must also check for some usable Ground Control Points. These are points on the 
coordinate grid that you can easily see and calculate X,Y coordinates based on the 
projection the map is in. (See Appendix A) 

Scan the map to a TIFF file 

Important: the current version of QGIS was tested for GeoTiff format only. So we will use only TIFF 
format for the lab. There is a problem with image rendering on QGIS for Windows. Apparently, QGIS 
can render ONLY georeferenced images. When I tried to open an image (w/o georef) the system shows 
it in TOC, but there is no image on the map canvas. For the exercise we use amherstopo.tif image, not 
the JPEG. 
You need a scanner to scan your map. If it is a large map, you need a large (map) scanner. For projects, 
it will probably be better for you to try and work with maps that fit on an 8 x 11 sheet of paper. 

Before you do the scan, make sure you note the coordinates of grid lines that will be in your scanned 
image. Refer to Appendix A “Amherst Topo Map” as an example. It is critical that you include some 
grid “crosshairs” that you can use as ground control points. 

Scan the map to a TIFF file (or better yet a jpg file if the scanner software will do it). Refer to 
Appendix B, to learn about different image formats. 

To use the .tif(.jpg) file in a GIS we must first georeference it. If we brought it into a GIS package 
(QGIS in our case) as it is, it would have a simple Cartesian plane coordinate system that is based on 
the number of pixels in the file. We want to assign the .tif (.jpg) file to the correct projection system 
that it represents, and thus change the coordinate system to represent this projection. 

This involves (a) specifying the .tif (or .jpg’s) coordinate system in QGIS; (b) Digitizing specific 
control points; and (c) Rectifying or “stretching” the scanned image to fit the new projection. 

For the remainder of this excercise, please use datasets available at Appendix C 

Specifying the coordinate system for the image 
It is important to figure out cartographic information for images you plan to add spatial reference to. 
Read the data description section of the map to define projection, datum and units for the map. In this 
excersise we get the following from the data description section: 

• Projection: Universal Transverse Mercator 
• Datum: 1927 North American Datum 
• Zone: 18N 
• Map Units: meters 

At the next step we need to identify several points on the image for which it is possible to define 
coordinates. It is easier to select points located on "cross-hair" of the map. 

Figure 1: Defining coordinates of a control point



We use the scanned topo map to find out coordinates for four points. A detailed image is also available. 
The Table below summarizes X(East)/Y(North) coordinates for four control points: 

 The Table below summarizes X(East)/Y(North) coordinates for four control points: 

Ground Control Points with coordinates 
GCP 
ID X (East) Y (North) 

Point1 703000 4695000 
Point2 703000 4699000 
Point3 705000 4699000 
Point4 705000 4695000 
Figure 1: We will use this information to georeference the topo image. 

Georeferencing an Image with Georeferencing Tool/Extension 

Making Plugin available 
QGIS allows users to expand functionality of the application through additional modules or plug-ins. 
We need to add the Georeferencer plug-in to QGIS first. Click on Plugins > Plugin Manager on the 
main menu bar (Figure 2). 

Figure 2: Invoke Plugin Manager

The window with a list of available plugins will appear. Be sure that you check the Georeferencer 
plugin (Figure Ref). 
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Figure 3: Plugins Manager window

The Georeferencer plugin is now available on the system. In some versions of QGIS its button will 
appear on the menu bar (Figure 4a), in other versions you should click on Plugins > Georeferencer > 
Georeferencer (Figure 4b). 

Figure 4a: QGIS menu bar with a new button 

Figure 4b: QGIS menu bar

Now we can start using the georeferencing functionality of QGIS. 

file:///intro-fossgis-umass/index.php%3Ftitle=Image:PluginManagerWindow.jpg
file:///intro-fossgis-umass/index.php%3Ftitle=Image:NewGeoreferencingTool.jpg
file:///intro-fossgis-umass/index.php%3Ftitle=Image:Georeferencer_Plugin.jpg


Georeferencing procedure 
This section describes the major steps to georeference the image (Note: you do not need to add the 
image (raster) to the QGIS project). 

1. Start the Georeferer plugin, it will open the plugin window and the blank main plugin window. 
2. Specify the image you would like to georeference by clicking on the [...] button and selecting 

the file. (This is amherstopo.tif in our case. 

Figure 5: Georeferencer Plugin File Selection
3. The image will appear in the center of the main window. 
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Figure 6: Main Georeferencer Plugin Window

4. Before preceeding further, please take a moment to learn the navigation/control tools of the 
plugin: zoom-in, zoom-out, zoom to full extent, pan, add control point and delete control point. 

Figure 7: Plugin navigation and control tools
5. To add a control point, please zoom to a point you defined earlier (use zoom and pan tools). 
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Then click on the [add control point] tool, position the cursor over the selected point and left 
click. A dialog window will appear. 

Figure 8: Adding Control Points
Enter the X/Y coordinates and press [Ok]. 

6. You will see a point depicted by QGIS and a yellow text box with coordinates. 
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Figure 9: Results of registering point

7. If you make a mistake entering a point, use the [delete point] tool to remove the point 
8. Repeat steps 5-7 for the other three control points. Be sure that you enter the correct coordinates 

for each point (See Appendix A for a closer look). 
9. Then click the [Create] button (Figure 9.5) and close the Georeferencer window.  The'Create 

and load layer' button will create a world tiff file AND bring the georeferenced image into the 
TOC. For now however, we'll just create the world tiff file and load the georeferenced image 
ourselves so you can see what the world tiff file extension looks like (.wld) in windows 
explorer. 
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Figure 9.5: Navigation to 'Create' button

Fixing the tif world file: QGIS 0.8.x for Windows ONLY (Error Seems to 
be Corrected for QGIS 0.11.x- Skip this step) 
This sub-step is required only for users of QGIS0.8.x for Windows. Apparently, the new version of the 
Georeferencing plug-in (currently 0.8.x) has a bug, which causes incorrect calculations for one 
parameter in tif-world file. This bug was reported to the QGIS team and is expected to be fixed. 
Meanwhile, we've devised a workaround for this issue (Sorry--this is a bit complicated and ideally is 
something you shouldn't have to do if the software is working correctly. Remember QGIS is very new 
-- we're using a release that is not even version 1.0 yet! -- and the developers are still programming 
some of the fundamental components. This type of thing is a tradeoff of using newly developed open 
source software rather than using proprietary software that has been around.) 

To "fix" the world file for your "newly" georeferenced tif image you need to: 

1. open the tif world file for your image (it has the same name as the tif image and a *.wld 
extension). 

1. you can use any text editor (such as Windows Notepad or Wordpad found under 
Programs, Accessories) to edit the wld file (Figure 10a) 

2. the georefencing plugin creates a "world file" for the image. This file consists of 6 records: the 
first four records store information on pixel distortion(s). In other words, how much each pixel 
should be "stretched/shrinked" to cover correct area. As you see there is nothing really 
mysterious about the "world" file. 
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Figure 10a: Correcting the tif world file 

Apparently, due to this bug in the software, the plugin computes the X coordinate (number in 5th row) 
incorrectly. To fix it for the image we are using, please change the number in the fifth row to 701958. 
Then save the file. 

Adding data sets with different projections to one map 
1. Add the image you georeferenced to the project: [Layer > Add a Raster Layer] 
2. Add landuse data layer to the project [Layer > Add a Vector Layer] and select lus8.shp. 
3. Set "toggle overview" for both layers. (View> Check 'Overview' at bottom of list) It will allow 

you to see the spatial extent and a "preview" of layers in the left bottom corner of applicaton. 
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Figure 10: Adding Layers
4. You should notice that these datasets do not overlay. This is because the datasets are prepared 

with different projections. Modern GIS systems (including QGIS) allows you to reproject 
datasets "on the fly". You can think of this operation as a real-time units/projection conversion. 
You will need to enable the "on-the-fly" projection option and specify projection information 
for each layer. 

5. Let's enable "on-the-fly" projection and set the default projection for our project. [Settings > 
Project Properties], then select the Projection tab (See Figure 11 below). 
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Figure 11: Setting the Projection
Be sure that you check the Enable on the fly projection check-box. Then set a projection for 
the project. There are at least two ways to do that: 

1. Select projection via the projection tree/list: Projected coordinate system > Univsersal 
Transv. Mercator > NAD27/UTM zone 18N. Then click the [Ok] button. Please note 
that this projection setting has a spatial reference ID of 2098. We can use this ID as a 
shortcut for setting the projection. 

2. Check the (QGIS SRSID) radio button. Then enter 2098 into the search text box and 
click [Find]. Select this projection from the list and click [Ok].  You'll notice that the 
raster image disappears from the map view. That's ok. Continue on through the next step 
and it will come back. 

6. Now we must specify the projection information for each dataset/layer. 
1. To specify the projection settings for the image, right click on the raster layer in the table 

of contents (on the left side), select [Properties]. 
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Figure 12: Layer Projection
The "Raster Layer Properties" window will appear.
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Figure 13: Raster Properties
Select the [General] tab. To change the projection click on the [Change] button in the 
"Spatial Reference System" part of the window. The "Layer Projection Selector" window 
will appear. Use the same steps as we used for defining projection information for the 
project. (ID 2098, Projected Coordinate Systems > UTM > NAD27/UTM Zone 18N). 
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Figure 14: Setting Raster Projection
After that, new projection information is shown in "Spatial Reference System" field. 
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Figure 15: New Raster Projection

1. Setting projection information for the vector layer. At this step, set projection 
information for the land use layer in the same way that you did for the raster layer, 
except this time use ID: 2251 or Proejected Coordinate Systems > Lambert 
Conformal Conic > NAD83/Massachusetts Mainland 

2. The system should be able to "overlay" two datasets. (It should occur automatically, but press 
the "refresh" button if it doesn't). Image:.jpg 
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Figure 16: Correctly Projected Layers in QGIS v.0.11.0
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Appendix A. Scanned Image, map information 

Scanned Topo Image (Amherst, MA) 

Figure Ref: Scanned Topo with 4 control points defined
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Ground Control Points: Details 

Figure Ref: Coordinates of Control Points

Metadata 

Metadata

MassGIS database projection information 
Please check this website for details on Massachusetts State Plane coordinate system. 

http://www.mass.gov/mgis/dd-over.htm%7C
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Source: MassGIS website

Appendix B. Comparison of different image formats 
What is the difference between TIFF files and JPG files? They are different ways of storing images in a 
pixel or raster format. Some important information: 

• Pixels – picture image element 
• Image resolution – number of pixels in a digital image (higher resolution, better quality) 
• Monochrome image – each pixel is stored as a single bit (1 or a 0). A 640x480 monochrome 

image requires 37.5 KB of storage. 
• Gray-scale images – each pixel is stored as a number between 0 and 255. A 640x480 gray scale 

image requires over 300KB of storage. 
• 8-bit color images – Each pixel is represented by 1 byte. 256 possible colors out of the millions 

of colors possible. A 640 x 480 24-bit color image requires 307.2 KB of storage. Requires a 
color lookup table. 

• 24-bit color images – Each pixel is represented by 3 bytes (e.g., RGB). 256x256x256 possible 
combined colors (16,777,216). A 640 x 480 24-bit color image requires 921.6 KB of storage. 

Some standard system-independent formats 

• GIF – Graphics Interchange Format. Designed initially to transmit graphical images over phone 
lines via modems. 8-bit representation (256 colors). Suitable for images with few distinctive 
colors. GIF works well with images that have only a few colors such as line drawings. 

• JPG – Joint Photographics Experts Group. Compresses either full-color or grey-scale images. 
Works well with photographs, artwork, etc., but not well with lettering, simple cartoons, or line 
drawings. JPEG compression takes advantage of the limitations in human eyesight to make the 
image represented smaller without compromising what we see as humans. Basic jpeg stores 
images with 8 bits per color (24 bits for RGB, 8 bits for grey scale). 

• TIFF – Tagged Image File format. Stores many types of images (monochrome, gray scale, 8bit 
and 24 bit RGB) 

(For some good information on the various graphic file formats, see page 29 of the @OIT Fall 1999, 
Vol 5 #1, and also the @OIT Spring 2000 page 13 on .jpg compression.) 

See also www.cica.indiana.edu/graphics/image.formats.html for information on various types. 
Wikipedia provides excellent review of image formats 

http://en.wikipedia.org/wiki/Image_formats
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Appendix C: Dataset 
For this exercise we use a land use vector layer for the Town of Amherst, MA and a scanned topo TIFF 
image for the same area. Please download archived files from here: 

1. landuse data   [0.4Mb] 
2. topo   [6.1Mb] 
3. You can download landuse file from MassGIS site directly 

Then unzip files into your working/project folder. You should have the following files:

amhersttopo.tif
lus8.dbf
lus8.prj
lus8.sbn
lus8.sbx
lus8.shp
lus8.shp.xml
lus8.shx

Sources: MassGIS Landuse data tiled by town 

External Links
• Wikipedia articles on Image Formats: http://en.wikipedia.org/wiki/Image_formats 
• GDAL (Geospatial Data Abstraction Library): http://www.gdal.org 
• FW tools: http://fwtools.maptools.org/ 
• MassGIS: http://www.mass.gov/mgis/ 

http://www.mass.gov/mgis/
http://fwtools.maptools.org/
http://www.gdal.org/
http://en.wikipedia.org/wiki/Image_formats
http://www.mass.gov/mgis/ftplus.htm
http://www.mass.gov/mgis/
ftp://data.massgis.state.ma.us/pub/shape/landuse/lus8.exe
http://linuxlab.sbs.umass.edu/beginning-fossgis-umass/datasets/lab_georef/amhersttopo.tif.zip
http://linuxlab.sbs.umass.edu/beginning-fossgis-umass/datasets/lab_georef/lus8p1.zip
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